Cloud26 - Outage

Incident Report for Medius

Resolved

Access to AP Automation is restored for all customers.
Posted Mar 17, 2025 - 23:41 UTC

Investigating

Customers on Cloud26 may have problems connecting to AP Automation.
Posted Mar 17, 2025 - 23:31 UTC
This incident affected: AP Automation (Cloud26).