APA - Invoice postings

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 16:13 UTC

Update

Invoice posting should be back to normal for most customers. But we continue to monitor the situation.
Posted Apr 01, 2025 - 10:28 UTC

Investigating

We are currently investigating reports of slow postings of invoices for a subset of tenants.
Posted Apr 01, 2025 - 08:51 UTC