Cloud13 - Outage

Incident Report for Medius

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2026 - 10:10 UTC

Investigating

Customers on Cloud13 may have problems connecting to AP Automation. We are investigating the issue.
Posted Jun 12, 2026 - 07:46 UTC
This incident affects: AP Automation (Cloud13).