Expense - Performance degradation
Incident Report for Medius
Resolved
This incident has been resolved.
Thank you again for your patience.
Posted Nov 08, 2024 - 10:29 UTC
Identified
The issue has been identified and a fix is being implemented
Posted Nov 08, 2024 - 10:20 UTC
Investigating
Dear Users,
We're currently experiencing some slowness on our Web and mobile Apps.
Our team is on the task and we expect this issue to be temporary.
During this time, you might face some delays; if possible, we suggest postponing non-urgent tasks on Expensya.
We will keep you updated and will work promptly to resolve this issue soon.

We appreciate your patience.
Posted Nov 08, 2024 - 09:40 UTC
This incident affected: Services (Expense).