Capture - Delayed processing of incoming emails

Incident Report for Medius

Update

Capture alias management functionality is currently not working, as it depends on the same faulty component.
Posted Apr 07, 2026 - 12:03 UTC

Update

We have implemented an alternative connection to our mail service, bypassing the faulty component. Processing of the backlog of stuck emails has started. In parallel, we are continuing to work on restoring the faulty component to full operation.
Posted Apr 07, 2026 - 11:48 UTC

Update

We have started observing the issue in the US region as well.
Posted Apr 07, 2026 - 10:36 UTC

Identified

We have identified a faulty infrastructure component responsible for the integration with our mail service. We have reported the issue to our cloud provider support and are actively working on restoring it to operation.
Posted Apr 07, 2026 - 10:00 UTC

Investigating

We are currently experiencing an issue affecting the processing of a subset of incoming emails in Capture, causing some invoices to be delayed or not appear in the inbox. Our team is actively investigating.
Posted Apr 07, 2026 - 06:55 UTC
This incident affects: Services (Capture (Europe), Capture (US)).