Cloud26 - partial performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted May 19, 2026 - 06:58 UTC

Monitoring

We are currently monitoring the resources closely.
Posted May 19, 2026 - 06:26 UTC

Update

We have implemented mitigation measures and are actively monitoring the current metrics.
Posted May 18, 2026 - 12:11 UTC

Investigating

An incident impacting Cloud26 is currently affecting master data imports and report generation due to issues with the worker role. The root cause is still under investigation. Our team is working diligently to resolve the issue and minimize disruption. We apologize for any inconvenience caused and remain committed to delivering reliable services. Thank you for your patience as we address this matter.
Posted May 18, 2026 - 10:27 UTC
This incident affected: AP Automation (Cloud26).