Cloud02, 10, 20, 26 - Performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 10:38 UTC

Monitoring

A fix has been applied, and we have observed improvements in the application responsiveness. We are still closely monitoring the situation.
Posted Jun 13, 2025 - 09:11 UTC

Identified

A subset of users on Cloud02, Cloud10, Cloud20, and Cloud26 are experiencing performance degradation due to an overload on shared resources. Our team is actively working to migrate the affected resources to dedicated compute tiers to resolve the issue.
Posted Jun 13, 2025 - 08:34 UTC
This incident affected: AP Automation (Cloud02, Cloud10, Cloud20, Cloud26).