The fix has been applied. We are processing the backlog of failed invoices. At the same time, we are monitoring the system’s stability.
Posted Mar 06, 2026 - 14:18 UTC
Update
We are continuing to work on resolving the faulty infrastructure component. We managed to restore operation, but it eventually entered an unpaired state again.
Posted Mar 06, 2026 - 12:43 UTC
Update
We are still working on fixing the faulty infrastructure component.
Posted Mar 06, 2026 - 10:43 UTC
Identified
We have identified that one of the infrastructure components is in an impaired state. Unfortunately, a restart did not help. We are continuing our investigation.
Posted Mar 06, 2026 - 09:33 UTC
Investigating
We are experiencing an issue with exporting invoices from Capture to MediusGo. Almost all invoices sent to workflow after 07:45 CET are impacted. We are actively investigating the issue.
Posted Mar 06, 2026 - 09:27 UTC
This incident affected: Services (Capture (Europe)).