Cloud30 - Performance Degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 21:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2025 - 19:02 UTC

Investigating

We are currently investigating reports related to performance problems on cloud30.

We will report back as we know more.
Posted Mar 24, 2025 - 18:05 UTC
This incident affected: AP Automation (Cloud30).