Service Interruption Notice

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:29 UTC

Investigating

Due to ongoing issues with Cloudflare, access to support.medius.com is currently unavailable. We are monitoring the situation and will restore full functionality as soon as our service provider resolves the problem.
Posted Dec 05, 2025 - 09:07 UTC