Reporting Data Not Updating

Incident Report for Medius

Resolved

The issue affecting report data has been resolved. Reports are recovering and data is being processed automatically. Some reports may still reflect a slight delay while the system catches up — no action is required.

We apologize for the inconvenience.
Posted Aug 04, 2026 - 15:13 UTC

Update

We have identified the root cause of the reporting delay. Data is currently being processed. Reports will return to normal once processing is complete.

We will post a final update when reports are fully up to date.
Posted Aug 04, 2026 - 13:10 UTC

Investigating

We are currently investigating an issue where report data in Medius is not reflecting the latest updates. Invoices and other report data may appear outdated.

Our engineering team is actively investigating. We will provide an update as soon as we have more information.

We apologize for the inconvenience.
Posted Aug 04, 2026 - 11:21 UTC