The backlog has been fully processed. Email processing remains fully operational.
Posted Aug 17, 2026 - 16:02 UTC
Update
Processing of emails has been restored. We are now processing the backlog.
Posted Aug 17, 2026 - 14:42 UTC
Investigating
We are currently experiencing an issue affecting the processing of a subset of incoming emails in Capture. This may cause delays in some invoices appearing in the inbox. Our team is actively investigating.
Posted Aug 17, 2026 - 14:15 UTC
This incident affected: Services (Capture (Europe), Capture (US)).