Cloud39 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted Mar 21, 2023 - 17:11 UTC
Investigating
Customers on Cloud39 may have problems connecting to AP Automation. We are investigating the issue.
Posted Mar 21, 2023 - 17:07 UTC
This incident affected: AP Automation (Cloud39).