Processing times for email invoice ingestion have returned to normal as of 10:00 UTC.
Posted May 04, 2026 - 10:47 UTC
Identified
We have identified an issue affecting email invoice processing. We have applied additional processing capacity and are seeing clear signs of recovery.
Posted May 04, 2026 - 08:34 UTC
Investigating
We are currently investigating increased processing times for email-based invoice ingestion in the EU region. Customers submitting invoices via email may experience delays of up to 30 minutes before processing begins. All other ingestion channels (Pagero, API upload, e-invoice) are unaffected.
Posted May 04, 2026 - 08:12 UTC
This incident affected: Services (Capture (Europe)).