Analytics - Service degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 06:21 UTC

Monitoring

We have seen our products are back online. However still awaiting confirmation from Microsoft that the issue is fully resolved.
Posted Sep 03, 2025 - 22:07 UTC

Identified

We have seen degraded performance in our analytics product due to problems on the PowerBi platform.

Microsoft is working on resolving the problem
Posted Sep 03, 2025 - 22:05 UTC
This incident affected: Services (Analytics).