Capture — Pagero invoice ingestion disruption

Incident Report for Medius

Postmortem

What happened

On April 14 at approximately 14:00 CEST, a defect in the Pagero platform caused all requests from Medius Capture to the Pagero invoice API to be rejected. As a result, no invoices were retrieved from Pagero during the disruption period.

The Medius Capture integration service continued to operate and retried automatically throughout the disruption. When the Pagero platform recovered, Capture automatically resumed retrieving invoices without any manual intervention and began processing the accumulated backlog.

We became aware of the issue at approximately 08:30 CEST on April 15 following a customer report.

Customer impact

  • All Pagero invoice ingestion in the European region was interrupted from approximately 14:00 CEST on April 14 until ~11:20 CEST on April 15.
  • Invoices that were available in Pagero during this period were not retrieved or processed until after service was restored.
  • The accumulated invoice backlog was fully processed by approximately 13:00 CEST on April 15 — no invoices were lost.
  • Customers in the US region and non-Pagero channels were not affected.

Root cause

The disruption was caused by a defect in the Pagero platform. A supplier submitted an invoice containing an invalid date value that Pagero's API could not handle, causing the API to reject all requests during the affected window. This was confirmed and resolved by Pagero support.

Posted Apr 15, 2026 - 15:43 UTC

Resolved

The incident has been resolved. The backlog of invoices that accumulated during the disruption has been processed.
Posted Apr 15, 2026 - 13:40 UTC

Monitoring

Processing of Pagero invoices has been restored. The issue on the Pagero platform has been resolved and our systems are now successfully retrieving invoices. We are monitoring to confirm full recovery and that the backlog of affected invoices is being processed.
Posted Apr 15, 2026 - 09:44 UTC

Identified

The disruption is caused by a problem with the Pagero platform, which we have reported to Pagero and are working with them to resolve. We will provide a further update once we have more information.
Posted Apr 15, 2026 - 08:27 UTC

Investigating

We are currently experiencing an issue affecting the processing of incoming invoices from Pagero in the Europe region. Our systems have been unable to retrieve invoices from Pagero since approximately 12:00 UTC on April 14th. We are actively investigating the cause.
Posted Apr 15, 2026 - 07:30 UTC
This incident affected: Services (Capture (Europe)).