Analytics - Degraded performance of Power BI reports

Incident Report for Medius

Resolved

The issue in Power BI service was fixed and reports are operating normally.
Posted Mar 17, 2025 - 15:35 UTC

Monitoring

Metrics are stabilizing, we are monitoring the situation.
Posted Mar 17, 2025 - 14:07 UTC

Identified

Power BI service experiences an outage, which impacts Analytics reports. The Fire Station is not affected. Customers may experience performance issues when loading the Analytics reports (reports loading very slowly or not loading at all). Microsoft is investigating the issue on Power BI side.
Posted Mar 17, 2025 - 09:53 UTC
This incident affected: Services (Analytics).