The backlog has been fully processed. We are currently monitoring the system’s stability.
Posted Mar 12, 2026 - 21:00 UTC
Monitoring
The email service is now fully restored. All new incoming emails should be processed without delay, and we have also started processing the backlog of stuck messages.
Posted Mar 12, 2026 - 20:13 UTC
Update
The issue with our mail service remains unresolved, and we still have no response from the provider’s support.
Posted Mar 12, 2026 - 19:01 UTC
Update
We are still experiencing issues with our mail service. The problem has been reported to their support team, but there has been no breakthrough in their investigation so far.
Posted Mar 12, 2026 - 18:19 UTC
Identified
We are experiencing performance degradation in Capture when processing invoice deliveries via email, caused by an issue with our mail service provider.