Cloud39 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted May 25, 2023 - 04:30 UTC
Investigating
Customers on Cloud39 may have problems connecting to AP Automation. We are investigating the issue.
Posted May 25, 2023 - 04:29 UTC
This incident affected: AP Automation (Cloud39).