Expense - Availability Issue Due to Azure Incident

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 08:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 29, 2025 - 18:29 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:09 UTC

Investigating

We are currently experiencing availability issues in Expensya due to an ongoing Microsoft Azure incident impacting access to Azure Portal resources.

Our teams are closely monitoring the situation and collaborating with Microsoft to restore full functionality as quickly as possible.

We will provide updates as soon as new information becomes available.

Thank you for your patience and understanding.
Posted Oct 29, 2025 - 16:57 UTC
This incident affected: Services (Expense).