Resolved
This incident has been resolved.
Posted Oct 21, 2025 - 18:02 UTC
Investigating
We’re currently investigating an issue that can cause some users to experience problems when clicking links in emails sent from our service. The issue is related to routing between our domain and the e-mail provider for our system.
We’ll share an update as soon as it’s resolved.
Posted Oct 21, 2025 - 17:47 UTC
This incident affected: AP Automation (Cloud02, Cloud03, Cloud04, Cloud08, Cloud10, Cloud13, Cloud14, Cloud17, Cloud18, Cloud20, Cloud21, Cloud22, Cloud23, Cloud24, Cloud25, Cloud26, Cloud27, Cloud30, Cloud32, Cloud34, Cloud37, Cloud38, Cloud39, Cloud40, Cloud41, Demo01, Demo02, Demo03, Demo07, Demo08).