Capture US delay with processing PDF invoices

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 17:06 UTC

Monitoring

The issue with our external OCR service provider has been mitigated. The backlog of impacted invoices has been processed, and invoice processing has returned to normal operations.
Posted Sep 23, 2026 - 16:10 UTC

Investigating

Due to an issue with our external OCR service provider, we are experiencing a delay in processing incoming PDF invoices in the US region. Approximately 10% of invoice ingestion is impacted.
Posted Sep 23, 2026 - 15:04 UTC
This incident affected: Services (Capture (US)).