A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 08:54 UTC
Identified
We have identified the likely root cause of the issue affecting Cloud40 and are currently planning the necessary steps to implement a fix. In the meantime, we have increased capacity to mitigate the impact and improve performance while we work on a permanent resolution. Thank you for your patience and understanding.
Posted Mar 19, 2025 - 17:24 UTC
Investigating
Incident affecting Cloud40 is causing performance degradation for some service instances, impacting user experience. The root cause is currently under investigation. Our team is diligently working to resolve the issue and prevent future occurrences. We apologize for any inconvenience and appreciate your patience as we remain committed to providing excellent customer service. Thank you for your understanding.