A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 21:27 UTC
Identified
The root cause has been identified. Ongoing infrastructure patching impacted OCR service performance. After temporarily overprovisioning the infrastructure, we were able to process the entire queue, and the system has returned to normal operation.
Posted Dec 09, 2025 - 21:27 UTC
Update
We are currently experiencing a high backlog of OCR jobs. The worker pool reached its maximum size and was unable to process incoming traffic fast enough. We have switched to manual scaling and doubled the number of workers. Processing is now catching up and the queue is shrinking.
Posted Dec 09, 2025 - 20:23 UTC
Investigating
We are experiencing significant performance degradation in Capture OCR. We are investigating the issue.