Cloud10 - Outage

Incident Report for Medius

Resolved

Access to AP Automation is restored for all customers.
Posted May 11, 2025 - 00:40 UTC

Investigating

Customers on Cloud10 may have problems connecting to AP Automation.
Posted May 10, 2025 - 20:09 UTC
This incident affected: AP Automation (Cloud10).