Capture performance degradation

Incident Report for Medius

Resolved

The backlog of affected invoices has now been fully processed, and the system has remained stable.
Posted Mar 23, 2026 - 21:52 UTC

Monitoring

The system has remained stable since the last update regarding the processing of incoming invoices. We are continuing to work through the backlog of invoices affected by the incident.
Posted Mar 23, 2026 - 18:00 UTC

Update

The system has started to show signs of recovery. All invoices sent into the system after 15:30 UTC should now be processed in a timely manner. We have also started processing the backlog of stuck or failed invoices.
Posted Mar 23, 2026 - 16:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 23, 2026 - 15:49 UTC

Update

We are continuing to work on a fix for this issue. The majority of incoming traffic should now be processing, however a subset of it is still blocked. We have requested assistance from our cloud provider to help resolve the remaining problems.
Posted Mar 23, 2026 - 15:46 UTC

Update

The system is still struggling to return to normal operation. Unfortunately, in the meantime it has become even more unstable, and the performance impact is now more severe. We are attempting to overprovision our infrastructure to mitigate the impact.
Posted Mar 23, 2026 - 13:56 UTC

Identified

We have identified the root cause of the issue affecting the processing of incoming emails in Capture. The disruption was caused by an unexpected infrastructure upgrade on the environment hosting our application. This unplanned activity led to service instability.
We are working to stabilize the platform and mitigate the impact.
Posted Mar 23, 2026 - 09:34 UTC

Investigating

We are currently experiencing an issue in Capture that is affecting the processing of incoming emails. This is causing delays in displaying them in the APA/MediusGo inbox. Our team is actively investigating the issue.
Posted Mar 23, 2026 - 08:44 UTC
This incident affected: Services (Capture (Europe), Capture (US)).