Cloud13 - Outage

Incident Report for Medius

Resolved

Access to AP Automation is restored for all customers.
Posted Apr 24, 2025 - 04:46 UTC

Investigating

Customers on Cloud13 may have problems connecting to AP Automation. We are investigating the issue.
Posted Apr 24, 2025 - 04:19 UTC
This incident affected: AP Automation (Cloud13).