Capture service disturbances

Incident Report for Medius

Resolved

A faulty UPS caused a partial power outage, but all services are operating normally now.
Posted Apr 01, 2025 - 14:55 UTC

Update

We observe little impact on our services at the moment, but continue to monitor the situation.
Posted Apr 01, 2025 - 10:56 UTC

Monitoring

The capture service is currently expediting some disturbances due to issue at our upstream cloud infrastructure provider. We're in contact with them and working together to adress the issue. Some invoices may see additional delays.
Posted Apr 01, 2025 - 09:46 UTC
This incident affected: Services (Capture (Europe)).