Supplier Management – Performance Degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 10:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2026 - 17:25 UTC

Investigating

We are currently experiencing degraded performance in the European region. The team is actively investigating the issue.
Posted Jan 21, 2026 - 16:12 UTC
This incident affected: Services (Supplier Mgmt).