APA - Performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 19:04 UTC

Investigating

We are currently investigating performance degradation of customers in US region.
Posted Apr 01, 2025 - 16:25 UTC