Cloud39 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted Jul 19, 2024 - 17:40 UTC
Investigating
Customers on Cloud39 may have problems connecting to AP Automation.
Posted Jul 19, 2024 - 17:10 UTC
This incident affected: AP Automation (Cloud39).