Pay - Problems accessing application

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 08:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 20:33 UTC

Update

Issue is still being worked on by Microsoft.
Posted Oct 29, 2025 - 20:08 UTC

Identified

Microsoft are still working on resolving the problem.
Posted Oct 29, 2025 - 19:01 UTC

Investigating

We are currently investigating an issue with resource loading from our Content Delivery Network (CDN) in Microsoft Azure. This may cause problems accessing or loading parts of the application for a subset of users.
Posted Oct 29, 2025 - 18:03 UTC
This incident affected: Services (Pay).