Degraded Performance in Reporting (US)

Incident Report for Medius

Resolved

The issue has been mitigated and service is operational.
Posted Sep 14, 2026 - 21:31 UTC

Investigating

We are currently experiencing intermittent performance issues affecting report generation and data retrieval in the US region. Customers in this region may encounter delays or timeouts when accessing reports.
This has been identified as being caused by a confirmed incident with the Azure Databricks SQL component in the US region. Our team is actively monitoring the situation and working with Databricks as they resolve the issue. We will provide updates as more information becomes available.
Posted Sep 14, 2026 - 20:47 UTC
This incident affected: Services (Data Platform (US)).