Capture performance degradation

Incident Report for Medius

Resolved

The issue has been mitigated, and invoice processing performance has returned to normal. Processing remained stable during the monitoring period. This incident is now resolved.
Posted Aug 26, 2026 - 09:05 UTC

Monitoring

The issue has been mitigated, and invoice processing performance has returned to normal.
Posted Aug 26, 2026 - 08:38 UTC

Investigating

We are investigating performance degradation affecting Medius Capture in the European region. Customers may experience delays in invoice processing.
Posted Aug 26, 2026 - 06:50 UTC
This incident affected: Services (Capture (Europe)).