Cloud10 - Outage

Incident Report for Medius

Resolved

Access to AP Automation is restored for all customers.
Posted Feb 13, 2025 - 08:59 UTC

Investigating

Customers on Cloud10 may have problems connecting to AP Automation. We are investigating the issue.
Posted Feb 13, 2025 - 08:05 UTC
This incident affected: AP Automation (Cloud10).