Cloud17, 30, 34 - Performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 18:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 16:06 UTC

Update

The majority of affected customers should be seeing significant improvements. We are still facing issues with one of the affected resources and are continuing to work on the problem.
Posted Jul 14, 2025 - 15:37 UTC

Identified

Customers on clouds17, 30, 34 may experience degraded performance or issues accessing the application due to problems with scaling up a shared database resource. We are working with Azure support to resolve the issue.
Posted Jul 14, 2025 - 13:14 UTC
This incident affected: AP Automation (Cloud17, Cloud30, Cloud34).