ERP Cloud Connectors – Master Data Import Delays

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 18:19 UTC

Identified

We have observed longer-than-usual processing times for Master Data imports throughout the day. Our team has identified contributing factors and is actively working on resolving the issue. Performance has started to improve, and we continue to monitor the situation closely.
Posted Oct 31, 2025 - 16:42 UTC
This incident affected: ERP Cloud Connectors (Dynamics 365 FO, Dynamics 365 BC, Dynamics Ax 2012, NetSuite, SAP).