We are currently experiencing performance issues with report data retrieval in our application in Europe. This is caused by degraded performance of the Azure Databricks SQL Warehouse. Our team is actively working with the Databricks support team to investigate and resolve the issue. We will provide updates as soon as more information becomes available. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Apr 03, 2026 - 15:23 UTC
Investigating
We are currently experiencing intermittent performance issues affecting report generation and data retrieval in the European region. Customers in this region may encounter delays or timeouts when accessing reports. Our team is actively investigating and working to resolve the issue as quickly as possible. We will provide updates as more information becomes available.
Posted Apr 03, 2026 - 11:56 UTC
This incident affected: Services (Data Platform (EU)).