Capture - delay with processing incoming invoices

Incident Report for Medius

Resolved

The entire backlog has been processed, and the processing of new invoices remains stable.
Posted Nov 03, 2025 - 15:47 UTC

Monitoring

The root cause has been identified and a fix has been applied. Since 13:38 UTC, no new failures have occurred. We are currently processing the backlog of stuck invoices.
Posted Nov 03, 2025 - 14:15 UTC

Update

The issue is still ongoing. Impacted invoices are stuck and cannot be sent to the inbox at the moment. We are continuing to investigate the issue.
Posted Nov 03, 2025 - 12:18 UTC

Investigating

We are experiencing an issue with processing a subset of invoices sent to Capture after 9:55 UTC. We are currently investigating the issue.
Posted Nov 03, 2025 - 10:57 UTC
This incident affected: Services (Capture (Europe)).