Capture OCR performance degradation

Incident Report for Medius

Resolved

As the OCR service has remained stable for several hours, we are closing the incident as resolved.
Posted Mar 22, 2025 - 08:21 UTC

Monitoring

A fix has been implemented and released. OCR stability has been verified, and it has been confirmed that the performance issue is no longer occurring.
Posted Mar 21, 2025 - 21:32 UTC

Identified

We have identified the root cause and are currently working on implementing a fix. At the same time, we are mitigating the impact on OCR timings by adjusting infrastructure scaling to accommodate the current service impairment. At the moment, there shouldn't be any delays (longer than average) in processing incoming invoices.
Posted Mar 21, 2025 - 09:09 UTC

Investigating

After the last upgrade of Capture OCR, we have observed a performance degradation in processing incoming invoices. We are actively investigating the issue and working on mitigating it.
Posted Mar 21, 2025 - 08:01 UTC
This incident affected: Services (Capture (Europe)).