Cloud20 - Outage

Incident Report for Medius

Resolved

Access to AP Automation is restored for all customers.
Posted Sep 27, 2023 - 07:33 UTC

Investigating

Customers on Cloud20 may have problems connecting to AP Automation. We are investigating the issue.
Posted Sep 27, 2023 - 05:58 UTC
This incident affected: AP Automation (Cloud20).