Cloud39 - Performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 12:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 06:19 UTC

Update

We have identified the issue. Working on the solution.
Posted Mar 19, 2025 - 05:40 UTC

Investigating

Customers on Cloud39 connecting to AP Automation may experience slowness on both our Web and mobile Apps.
Our team is actively working on the issue.

We will keep you informed and are working quickly to resolve this issue.

Thank you for your patience
Posted Mar 19, 2025 - 04:40 UTC
This incident affected: AP Automation (Cloud39).