Medius Capture - Performance degradation

Incident Report for Medius

Resolved

The faulty component has now fully recovered and is operating normally.
Posted Mar 14, 2026 - 03:00 UTC

Update

The backlog has been processed, and incoming traffic should now be handled without delay. However, we are still working on restoring full operation of the faulty component.
Posted Mar 13, 2026 - 16:17 UTC

Update

Temporarily, we have switched to an alternative solution to retrieve information from the mail service and have begun processing the backlog through it.
Posted Mar 13, 2026 - 15:11 UTC

Identified

We have identified that one component of the Capture infrastructure is experiencing an issue communicating with our email service. We are working on restoring it to operation. Unfortunately, restarting the service has not resolved the problem.
Posted Mar 13, 2026 - 14:48 UTC

Investigating

We are experiencing performance degradation in Capture when processing invoice deliveries via email. We are investigating the issue.
Posted Mar 13, 2026 - 13:34 UTC
This incident affected: Services (Capture (US)).