Cloud23 - Performance degradation

Incident Report for Medius

Update

We are continuing to monitor for any further issues.
Posted Sep 16, 2026 - 07:43 UTC

Monitoring

Performance has stabilized. We continue to monitor the situation closely.
Posted Sep 15, 2026 - 16:07 UTC

Investigating

We are currently investigating this issue.
Posted Sep 15, 2026 - 14:52 UTC
This incident affects: AP Automation (Cloud23).