Capture performance issue

Incident Report for Medius

Postmortem

At 12:00 UTC The Capture service experienced an unexpected disruption due to an issue with a third-party vendor that we utilize for Optical Character Recognition (OCR) processing. This issue prevented us from fetching the processed files for a subset of invoices.

By 16:30 UTC the issued was mitigated at the vendor and the failing invoices could be processed.

By 18:00 UTC the backlog was processed and the Capture service was back to normal again

Posted Oct 03, 2024 - 20:46 UTC

Resolved

System back to normal
Posted Oct 03, 2024 - 19:56 UTC

Monitoring

Invoices processing normally again, some backlog to manage
Posted Oct 03, 2024 - 16:56 UTC

Identified

Issue with 3rd party vendor
Posted Oct 03, 2024 - 15:50 UTC

Investigating

Some invoices are currently taking longer than usual to process
Posted Oct 03, 2024 - 15:30 UTC
This incident affected: Services (Capture (Europe), Capture (US)).