Data Platform (US) - Performance degradation

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 16:13 UTC

Investigating

We are currently experiencing a performance degradation in the Data Platform affecting the US region. The issue is related to compute resource availability, and we are investigating in coordination with our cloud providers, including Azure Databricks: https://status.azuredatabricks.net/
Posted Apr 24, 2026 - 14:51 UTC
This incident affected: Services (Data Platform (EU)).