Cloud21 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted May 23, 2023 - 13:18 UTC
Investigating
Customers on Cloud21 may have problems connecting to AP Automation. We are investigating the issue.
Posted May 23, 2023 - 13:09 UTC
This incident affected: AP Automation (Cloud21).