Medius Capture - Performance degradation
Incident Report for Medius
Postmortem

Between January 13th and 16th, Medius Capture experienced delays and performance issues in processing some invoices due to a problem with a third-party OCR service.

We mitigated the issue by reprocessing and redirecting some of the impacted invoices to an alternate OCR service.

The OCR service vendor identified the root cause to a recent system change causing an automated maintenance job to be ineffective. They have implemented measures to prevent future incidents.

We apologize for any inconvenience this incident may have caused and appreciate your understanding and patience. We remain committed to ensuring the reliability of our services.

Posted Jan 22, 2025 - 14:34 UTC

Resolved
As the resolution remains effective, this incident is now considered resolved.
Posted Jan 17, 2025 - 08:27 UTC
Update
We were notified by the OCR service support team about resolving an issue on their side and have observed significant performance improvement in processing time for incoming invoices in Capture. We will continue to monitor to ensure the relief is long-term.
Posted Jan 16, 2025 - 17:01 UTC
Update
The upstream vendor issues remains. We continue to monitor and expedite as we can.
Posted Jan 16, 2025 - 07:50 UTC
Update
The upstream vendor issues remains. We continue to monitor and expedite as we can.
Posted Jan 15, 2025 - 07:41 UTC
Update
The upstream vendor issues remains. We continue to monitor and expedite as we can.
Posted Jan 14, 2025 - 08:29 UTC
Update
The upstream vendor issues remains. We continue to monitor and expedite as we can.
Posted Jan 13, 2025 - 14:49 UTC
Monitoring
We are currently experiencing performance issues with a third-party OCR service that are impacting some customers. We are working to expedite processes to ensure invoices reach inboxes as swiftly as possible.
Posted Jan 13, 2025 - 11:23 UTC
This incident affected: Services (Capture (Europe)).