Cloud26 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted Nov 27, 2024 - 09:02 UTC
Investigating
Customers on Cloud26 may have problems connecting to AP Automation. We are investigating the issue.
Posted Nov 27, 2024 - 08:32 UTC
This incident affected: AP Automation (Cloud26).