Capture — Delayed Invoice Processing (US)

Incident Report for Medius

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 19:42 UTC

Monitoring

Invoice processing for Capture US customers has been restored. Our systems have recovered and are processing invoices at normal capacity as of approximately 18:50 UTC.
Invoices submitted between 15:00–19:00 UTC today may have experienced delays of up to 90 minutes. All invoices have been processed — no data has been lost.
We will continue monitoring to ensure full stability and will post a final update once we have confirmed complete recovery.
Posted Apr 24, 2026 - 19:14 UTC

Identified

We have identified the root cause of the delays. Invoice processing for Capture US customers is currently experiencing significant slowdowns due to an infrastructure issue with our cloud provider in the US region. This is preventing our systems from scaling up to handle the current workload as expected.
We are actively working with our cloud provider to resolve the underlying infrastructure issue and restore normal processing capacity.
Invoices submitted after 15:00 UTC are most affected and may experience delays of up to 90 minutes.
Posted Apr 24, 2026 - 18:24 UTC

Investigating

We are currently investigating elevated invoice processing times affecting Capture US customers. Processing delays are currently around 50 minutes above normal thresholds. Our engineering team has identified the cause and infrastructure scaling has been triggered to restore normal throughput.
Posted Apr 24, 2026 - 16:48 UTC
This incident affected: Services (Capture (US)).